<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="ja">
	<id>https://wikippe.e-do-match.com/index.php?action=history&amp;feed=atom&amp;title=Internet_Message_Access_Protocol</id>
	<title>Internet Message Access Protocol - 版の履歴</title>
	<link rel="self" type="application/atom+xml" href="https://wikippe.e-do-match.com/index.php?action=history&amp;feed=atom&amp;title=Internet_Message_Access_Protocol"/>
	<link rel="alternate" type="text/html" href="https://wikippe.e-do-match.com/index.php?title=Internet_Message_Access_Protocol&amp;action=history"/>
	<updated>2026-11-14T00:37:01Z</updated>
	<subtitle>このウィキのこのページに関する変更履歴</subtitle>
	<generator>MediaWiki 1.44.2</generator>
	<entry>
		<id>https://wikippe.e-do-match.com/index.php?title=Internet_Message_Access_Protocol&amp;diff=8311&amp;oldid=prev</id>
		<title>2014年5月8日 (木) 01:10に101.102.56.189による</title>
		<link rel="alternate" type="text/html" href="https://wikippe.e-do-match.com/index.php?title=Internet_Message_Access_Protocol&amp;diff=8311&amp;oldid=prev"/>
		<updated>2014-05-08T01:10:34Z</updated>

		<summary type="html">&lt;p&gt;&lt;/p&gt;
&lt;p&gt;&lt;b&gt;新規ページ&lt;/b&gt;&lt;/p&gt;&lt;div&gt;{{IPstack}}&lt;br /&gt;
&amp;lt;!-- Edit the stack image at: Template:IPstack --&amp;gt;&lt;br /&gt;
&lt;br /&gt;
&amp;#039;&amp;#039;&amp;#039;Internet Message Access Protocol&amp;#039;&amp;#039;&amp;#039;（インターネット メッセージ アクセス プロトコル、&amp;#039;&amp;#039;&amp;#039;IMAP&amp;#039;&amp;#039;&amp;#039;） は、[[メールサーバ]]上の[[電子メール]]にアクセスし操作するための[[プロトコル]]。クライアントとサーバが[[Transmission Control Protocol|TCP]]を用いて通信する場合、通常サーバー側はIMAP2, IMAP4では[[ポート番号]]143番、IMAP3では220番を利用する。&lt;br /&gt;
&lt;br /&gt;
== 概要 ==&lt;br /&gt;
[[Post Office Protocol|POP]] はユーザが利用中のサーバからクライアントにメールをダウンロードし、ダウンロードがすんだメールはサーバから削除することを標準的な利用形態とするのに対し、IMAP はメールをメールサーバ上に保存したまま管理する（RFC 1733 参照）。この特性により、複数のコンピュータから同一[[アカウント]]のメールを読む場合に、メールの未読状態等の属性やメールフォルダの構成等が一元的に管理できる利点がある。プロトコルの仕様が複雑であったためあまり広く普及しなかったが、[[Netscapeシリーズ|Netscape]] や [[Internet Explorer]] に標準で含まれているメールソフトが IMAP4 に対応し、また相互接続試験やプロトコルの様々な改訂・拡張により相互運用性が高まったため、利用者が広がった。&lt;br /&gt;
&lt;br /&gt;
== POPとの比較 ==&lt;br /&gt;
POPは以下の利点と欠点を持つ。&amp;lt;!-- 欠点と利点が少々違っていると思いますので、以下、コメントします　--&amp;gt;&lt;br /&gt;
* POPプロトコルは常時接続ではないネットワークアクセスにおいて有利である。&lt;br /&gt;
* ユーザーはメールのローカルコピーを取得し、メールをオフラインで読むことができる。&lt;br /&gt;
* メールフォルダは[[電子メールクライアント|MUA]]より管理されプロトコルには含まれていない。&lt;br /&gt;
* 通常、メールはサーバから取得された直後に削除する。すなわちサーバは未読のメールだけ保持しておけばよい。&lt;br /&gt;
* 複数の端末からメールを取得すると、別の端末でダウンロードしたローカルコピーにアクセスできない。&lt;br /&gt;
* メールをサーバに保存する手段がない。&amp;lt;!-- 消さない通信が可能です--&amp;gt;&lt;br /&gt;
* メールを取得する際にメールの一部のみを取得する手段がオプションとなっている。&lt;br /&gt;
IMAPはPOPの利点を生かしつつ欠点を解消している。&lt;br /&gt;
* IMAPプロトコルはオンライン・オフラインいずれでも利用できる。&amp;lt;!-- popよりオフラインが苦手です　--&amp;gt;&lt;br /&gt;
* オフライン操作はMUA側でトランザクションログとして保存し、サーバに接続した時点でコミットすることで反映できる。&lt;br /&gt;
* 通常、メールはサーバに常時保存される。ローカルコピーを取得した時点でサーバから削除することもできる。&lt;br /&gt;
* 複数の端末からメール状態を一元管理することができる。複数の端末で同じメールを読むことができる。&lt;br /&gt;
* メールフォルダはプロトコルの一部として標準化されており、メールソフトの種類に関係なくフォルダを管理できる。&lt;br /&gt;
* メールの一部のみを取得できる。ヘッダのみの取得、マルチパートのテキスト部分のみの取得といった操作が可能。&lt;br /&gt;
* メールをサーバに保存する手段がある。フォルダ全体のスナップショットを別のサーバに転送することもできる。&lt;br /&gt;
* IMAP4より古いIMAPはリモート実行によるプロトコルの複雑さとセキュリティ上の懸念があった。IMAP4では改善された。&lt;br /&gt;
* メールサーバはメールのオリジナルを管理しなければならない。大規模システムでは莫大な量のメール管理が必要となる。&lt;br /&gt;
&lt;br /&gt;
== IMAPの採用例 ==&lt;br /&gt;
=== サーバ ===&lt;br /&gt;
* [[Courier-MTA|Courier-IMAP]]&lt;br /&gt;
* [http://www.washington.edu/imap/ UW IMAP]&lt;br /&gt;
* [[Cyrus IMAP server]]&lt;br /&gt;
* [[Dovecot]]&lt;br /&gt;
&lt;br /&gt;
=== クライアント ===&lt;br /&gt;
* [[メール (アップルのソフトウェア)|メール]]&lt;br /&gt;
* [[Becky! Internet Mail]]&lt;br /&gt;
* [[Eudora]]&lt;br /&gt;
* [[Gaucho Internet Mailer]]&lt;br /&gt;
* [[Gnus]]&lt;br /&gt;
* [[Mew]]&lt;br /&gt;
* [[Microsoft Entourage]]&lt;br /&gt;
* [[Microsoft Outlook Express]]&lt;br /&gt;
* [[Microsoft Outlook]]&lt;br /&gt;
* [[Mozilla Thunderbird]]&lt;br /&gt;
* [[Mutt]]&lt;br /&gt;
* [[Opera]] M2&lt;br /&gt;
* [[Shuriken|Shuriken Pro4]]&lt;br /&gt;
* [[Sylpheed]]&lt;br /&gt;
* [[Winbiff]]&lt;br /&gt;
* [[Wanderlust]]&lt;br /&gt;
&lt;br /&gt;
=== サービス ===&lt;br /&gt;
* [[MobileMe]] - [[アップル インコーポレイテッド|アップル]]&lt;br /&gt;
* [[AIM Mail]] - [[AOL]]&lt;br /&gt;
* [[Gmail]] - [[Google]]&lt;br /&gt;
* [[Outlook.com]] - [[マイクロソフト]]&lt;br /&gt;
&lt;br /&gt;
== RFC ==&lt;br /&gt;
* RFC 5464 - The IMAP METADATA Extension &lt;br /&gt;
* RFC 5258 - Internet Message Access Protocol version 4 - LIST Command Extensions&lt;br /&gt;
* RFC 5257 - Internet Message Access Protocol - ANNOTATE Extension&lt;br /&gt;
* RFC 5256 - Internet Message Access Protocol - SORT and THREAD Extensions&lt;br /&gt;
* RFC 5255 - Internet Message Access Protocol Internationalization&lt;br /&gt;
* RFC 5182 - IMAP Extension for Referencing the Last SEARCH Result&lt;br /&gt;
* RFC 5162 - IMAP4 Extensions for Quick Mailbox Resynchronization&lt;br /&gt;
* RFC 5161 - The IMAP ENABLE Extension&lt;br /&gt;
* RFC 5092 - IMAP URL Scheme&lt;br /&gt;
* RFC 5032 - WITHIN Search Extension to the IMAP Protocol&lt;br /&gt;
* RFC 4978 - The IMAP COMPRESS Extension&lt;br /&gt;
* RFC 4959 - IMAP Extension for [[Simple Authentication and Security Layer]] (SASL) Initial Client Response &lt;br /&gt;
* RFC 4731 - IMAP4 Extension to SEARCH Command for Controlling What Kind of Information Is Returned&lt;br /&gt;
* RFC 4551 - IMAP Extension for Conditional STORE Operation or Quick Flag Changes Resynchronization&lt;br /&gt;
* RFC 4550 - Internet Email to Support Diverse Service Environments (Lemonade) Profile&lt;br /&gt;
* RFC 4549 - Synchronization Operations for Disconnected IMAP4 Clients&lt;br /&gt;
* RFC 4469 - Internet Message Access Protocol (IMAP) CATENATE Extension &amp;#039;&amp;#039;([http://www.kasai.fm/wiki/imap_cat 日本語訳])&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 4468 - Message Submission BURL Extension&lt;br /&gt;
* RFC 4467 - Internet Message Access Protocol (IMAP) - URLAUTH Extension&lt;br /&gt;
* RFC 4466 - Collected Extensions to IMAP4 ABNF&lt;br /&gt;
* RFC 4416 - Goals for Internet Messaging to Support Diverse Service Environments &lt;br /&gt;
* RFC 4315 - Internet Message Access Protocol (IMAP) - UIDPLUS extension&lt;br /&gt;
* RFC 4314 - IMAP4 Access Control List (ACL) Extension&lt;br /&gt;
* RFC 3691 - IMAP UNSELECT command&lt;br /&gt;
* RFC 3516 - IMAP4 Binary Content Extension&lt;br /&gt;
* RFC 3503 - Message Disposition Notification (MDN) profile for IMAP&lt;br /&gt;
* RFC 3502 - IMAP MULTIAPPEND Extension&lt;br /&gt;
* RFC 3501 - &amp;#039;&amp;#039;&amp;#039;INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1&amp;#039;&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 3348 - IMAP4 Child Mailbox Extension&lt;br /&gt;
* RFC 2971 - IMAP4 ID extension&lt;br /&gt;
* RFC 2683 - IMAP Implementation Recommendations&lt;br /&gt;
* RFC 2595 - Using TLS with IMAP4, POP3 and ACAP&lt;br /&gt;
* RFC 2359 - IMAP4 UIDPLUS extension &amp;#039;&amp;#039;(RFC 4315によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
&lt;br /&gt;
* RFC 2342 - IMAP4 Namespace&lt;br /&gt;
* RFC 2221 - IMAP4 Login Referrals&lt;br /&gt;
* RFC 2195 - IMAP/POP AUTHorize Extension for Simple Challenge/Response&lt;br /&gt;
* RFC 2193 - IMAP4 Mailbox Referrals&lt;br /&gt;
* RFC 2192 - IMAP URL Scheme &amp;#039;&amp;#039;(RFC 5092によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 2180 - IMAP4 Multi-Accessed Mailbox Practice&lt;br /&gt;
* RFC 2177 - IMAP4 IDLE command&lt;br /&gt;
* RFC 2095 - IMAP/POP AUTHorize Extension for Simple Challenge/Response &amp;#039;&amp;#039;(RFC 2195によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 2088 - IMAP4 non-synchronizing literals&lt;br /&gt;
* RFC 2087 - IMAP4 QUOTA extension&lt;br /&gt;
* RFC 2086 - IMAP4 ACL extension &amp;#039;&amp;#039;(RFC 4314によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
&lt;br /&gt;
* RFC 2061 - IMAP4 COMPATIBILITY WITH IMAP2BIS&lt;br /&gt;
* RFC 2060 - INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1 &amp;#039;&amp;#039;(RFC 3501によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 1733 - DISTRIBUTED ELECTRONIC MAIL MODELS IN IMAP4&lt;br /&gt;
* RFC 1732 - IMAP4 COMPATIBILITY WITH IMAP2 AND IMAP2BIS&lt;br /&gt;
* RFC 1731 - IMAP4 Authentication Mechanisms&lt;br /&gt;
* RFC 1730 - INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4 &amp;#039;&amp;#039;(RFC 2060によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
* RFC 1203 - INTERACTIVE MAIL ACCESS PROTOCOL - VERSION 3&lt;br /&gt;
* RFC 1176 - INTERACTIVE MAIL ACCESS PROTOCOL - VERSION 2&lt;br /&gt;
* RFC 1064 - INTERACTIVE MAIL ACCESS PROTOCOL - VERSION 2 &amp;#039;&amp;#039;(RFC 1176, RFC 1203によって改訂)&amp;#039;&amp;#039;&lt;br /&gt;
&lt;br /&gt;
== 関連項目 ==&lt;br /&gt;
* [[Application Configuration Access Protocol|ACAP]]&lt;br /&gt;
* [[POP3]]&lt;br /&gt;
* [[Simple Mail Transfer Protocol|SMTP]]&lt;br /&gt;
* [[プッシュ型電子メール]]&lt;br /&gt;
{{URI scheme}}&lt;br /&gt;
[[Category:アプリケーション層プロトコル]]&lt;br /&gt;
[[Category:電子メールのプロトコル]]&lt;/div&gt;</summary>
		<author><name>101.102.56.189</name></author>
	</entry>
</feed>